GMOS Longslit reduction problem: Unable to open logfile?

Home Forums Gemini Data Reduction GMOS Longslit reduction problem: Unable to open logfile?

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  jturner 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #1568

    Hojin Cho
    Participant

    Hi, all.

    I am using the latest version of GMOS pipeline.
    I need to reduce GMOS-N Hamamatsu longslit data, and I consulted with this tutorial to use PyRAF to reduce my data. I changed the pipeline a bit to my preference, which is included as attachment.

    So, I could run the pipeline up to creating master bias. While creating flat, following error message appeared and then it stopped.

    GEMEXTN ERROR 101 Unable to access file 'gsflatLog.txt'.
    ERROR- GSREDUCE: GEMEXTN returned a non-zero status. Exiting.
     
    ERROR - GSREDUCE: Program execution failed with 1 errors
    ERROR - there was a problem running GSREDUCE.  Stopping now.
     
    ERROR - GSFLAT: Program execution failed with 1 errors.

    I thought the problem occured because I used pyraf and it tends to be unstable. So I got another pipeline code from here, which is IRAF cl version of the same script. I also slightly modified this script as well. But the problem persists.

    I heard somewhere around here or iraf.net or so, that IRAF has length limit for parameters, that any parameter should be less than 1024 chars. I checked that, but I only have 4 flat field images.

    Also, my data set lack standard star observations, but since I fixed the pipeline not to look up for standard-related files and the problem occured at the flat-fielding stage, lack of standard star should be irrelevant.

    So, what would be the cause of this problem? I think that if I could just bypass that log file issue, I could do just fine, but I don’t know.

    Thanks in advance.

    0

    0
    #2021

    jturner
    Keymaster

    Hello,

    Can you rename or delete your existing log file, do “unset LC_TIME LC_ALL” (or if you are using tcsh “unsetenv LC_TIME LC_ALL”) and then try again, please? I think it may be a problem with IRAF not liking Asian characters in your log file. If that doesn’t work, could you please send the output of “env |grep LC_”? Hope that helps.

    Thanks,

    James.

    PS. We do recommend using PyRAF, which is what we’re primarily testing on nowadays.

    0

    0
Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.