gscalibrate does not calibrate

Home Forums Gemini Data Reduction gscalibrate does not calibrate

This topic contains 5 replies, has 2 voices, and was last updated by  donze 1 year, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1408

    donze
    Participant

    Hi,
    I’m trying to calibrate just one single spectrum and I receive the following message:

    GSCALIBRATE — Thu Oct 6 20:28:11 ART 2016

    input = a85[sci]
    output =
    outpref = c
    sfunction = sens.fits
    fluxscale = 1.00E15
    fl_ext = yes
    fl_flux = yes
    fl_vardq = no
    sci_ext = SCI
    ignoreaps = yes
    fl_fnu = no
    extinction = ctioextinct.dat
    key_airmass = AIRMASS
    key_exptime = EXPTIME
    observatory = Gemini-South
    GSCALIBRATE done. Exit status good –Thu Oct 6 20:28:11 ART 2016

    Everything seems to be ok. However, when I splot the spectrum units are still
    in counts and it is obviously not flux calibrated.
    Can somebody tell me what I’m doing wrong?
    thanks!

    0
    0
    #1410

    donze
    Participant

    Another detail that can be interesting.
    the calibrated spectra, file with the ‘c’ prefix does not exist.
    After running the task the new file is not created.

    0
    0
    #1411

    jturner
    Keymaster

    That’s odd. Can you try giving it the input filename without the “[sci]” extension?

    Cheers,

    James.

    0
    0
    #1412

    donze
    Participant

    Hi James,
    thanks for your answer.
    yes, I did that and I received an error message, because
    the task looks for the extension name where to do the calibration.

    regards

    0
    0
    #1413

    jturner
    Keymaster

    Just to be clear, the “[sci]” should not be included and I see the same problem as you if I do include it. If the task doesn’t work without the “[sci]”, I think you are seeing a second problem; what processing did you do before gscalibrate, eg. with gsreduce?

    0
    0
    #1414

    donze
    Participant

    ok, now I know!
    I combined 5 spectra with scombine task, and the spectra were not gscalibrated.
    In other words, some information is missed after the scombine task.
    Now I gscalibrated the spectra before combine them and problem solved.
    Thank you very much James!

    0
    0
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.